[Crash] 0.2112 Leafcutter freeplay crash

MikeSlugDisco

Community Manager
Staff member
Community Manager
#2
I think creature spawning in general is causing issues. You can get a 100% succesful crash on the Christmas level by just waiting for the first spawn. As soon as the poor spider starts saying "Aaah.." the first red dot appears and it crashes.
 

HofNerd

Colony
Extremely Helpful Person
#3
I think creature spawning in general is causing issues. You can get a 100% succesful crash on the Christmas level by just waiting for the first spawn. As soon as the poor spider starts saying "Aaah.." the first red dot appears and it crashes.
But in freeplay overground creatures spawn just fine? Unless it affects underground spawns only?
 

MikeSlugDisco

Community Manager
Staff member
Community Manager
#4
But in freeplay overground creatures spawn just fine? Unless it affects underground spawns only?
We'll see what happens once John starts digging a bit, the crashes are so consistent that I don't think it'll take long to identify and fix this issue. It's so prevalent that I imagine we'll do a hotfix for it rather than wait for more things to be done.
 

MikeSlugDisco

Community Manager
Staff member
Community Manager
#5
Ok, that was quick - issue identified! It's actually to do with the movement code (some new code assumes that everything with a colony ID also has a tile grid) and indeed does happen whenever something that is not in the player's colony spawns underground - through entering the nest, spawning from a spawner or a tile surfer. Hotfix on the way.
 
Top