Game will no longer load - worked fine prior

Hi - Anyone have a fix for loading issues. Empires used to load first time launching from Steam now it keeps taking me through this endless loop. I have tried different tips but I am stuck and my son loves this game more than me :D


  • Empire error 2.PNG
    Empire error 2.PNG
    364.6 KB · Views: 7
  • Empire error 3.PNG
    Empire error 3.PNG
    551.2 KB · Views: 6
  • Empire error.PNG
    Empire error.PNG
    492.5 KB · Views: 5
My system spec is
Device name DESKTOP-NE15R29
Processor Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz 3.40 GHz
Installed RAM 8.00 GB (7.20 GB usable)
Device ID 75ECBD6F-F168-461D-BC76-E9DA711B84A5
Product ID 00325-80550-01514-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Edition Windows 10 Home
Version 20H2
Installed on ‎19/‎12/‎2020
OS build 19042.985
Experience Windows Feature Experience Pack 120.2212.2020.0


  • display.PNG
    3.4 KB · Views: 0