[Bug] 0.231: Fire ants demo: Creature became 'lost' from targetting ant that entered a fire ant bridge?

HofNerd

Colony
Extremely Helpful Person
#1
I already posted this one on the Discord, but I am placing it here too just to be sure.

I saw a bombardier beetle displaying the yellow exclamation mark above it and die instantly shortly after.
My guess on what happened there is, that the beetle targeted an ant just before that ant entered a fire ant bridge. And that because of that the beetle was unable to path to its target and received the status of being 'lost', which killed it shortly thereafter.
 
#7
I'll probably put all the issues I find on this thread. A small oversight, hovering over the fire ant soldier icons do not light up the tiles in the group. It only lights up on the minimap.
 

Liam

Administrator
Staff member
Developer of EotU
#9
I already posted this one on the Discord, but I am placing it here too just to be sure.

I saw a bombardier beetle displaying the yellow exclamation mark above it and die instantly shortly after.
My guess on what happened there is, that the beetle targeted an ant just before that ant entered a fire ant bridge. And that because of that the beetle was unable to path to its target and received the status of being 'lost', which killed it shortly thereafter.
I saw this a couple times and tried to pretend it didn't happen. I like your theory, you're probably right. Will test this.
 

HofNerd

Colony
Extremely Helpful Person
#10
I saw this a couple times and tried to pretend it didn't happen. I like your theory, you're probably right. Will test this.
After seeing this bug happen a few more times, I am starting to think the fire ants are actually spotted while they are still on the bridge. (I saw a creature become lost with ants only exiting a newly build bridge.)

Edit:
Ok, I am 100% certain now that the ants are spotted while they are still on the bridge. I saw a creature become 'lost' while the bridge to it wasn't completed yet. (On reflex I snapped a picture the moment it happened. Ofcourse I wil not post it, but I can send it to you in a direct message if you want it.)

Bridges use the carts-mechanism also used for plant climbing, right? If so, why are the creatures on bridges spotted while creatures on plants are not...? Are the creatures on the plants un-spottable because the are not on-surface? If so, is there a way the ants on bridges could be perceived as on-surface? (I am really curious as to what is going on here. :) )

I am an idiot because I could have known the answer to my question here. I remember from watching a dev-stream where the path-finder debug info was visible that the bridge had to be pathed over as tile-surfaces. So that means it has to be tile-based.
 
Last edited:

Liam

Administrator
Staff member
Developer of EotU
#11
After seeing this bug happen a few more times, I am starting to think the fire ants are actually spotted while they are still on the bridge. (I saw a creature become lost with ants only exiting a newly build bridge.)

Edit:
Ok, I am 100% certain now that the ants are spotted while they are still on the bridge. I saw a creature become 'lost' while the bridge to it wasn't completed yet. (On reflex I snapped a picture the moment it happened. Ofcourse I wil not post it, but I can send it to you in a direct message if you want it.)
No need to send anything, I know what's going on now, actually both things happen and it needs 2 fixes. I've got something to stop non-bridge creatures being able to target creatures on the bridge but there's still an issue if something that was targeted off-bridge runs onto a bridge. I think because this is quite rare and re-targeting wont be possible, we should get away with a little bodge that's specific to this situation.
 
Top